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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used in the following circumstances:
o Keyboard entries that should be typed in their entirety exactly as shown. For example,
“copy file1 ” means you must type the word copy, then type a space, then type file1.

o On-screen prompts and messages, names of options and text fields, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter ” means to press
the key labeled Enter.

l Italic type is used in the following circumstances:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copyfilename” means you must type the word copy, then type a
space, then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (e.g., Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, then press
the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and
contains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Schematic >Ground "
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This instruction means that you should click theGround command on the Schematic
ribbon tab. An image of the command icon, or a partial view of the ribbon, is often included
with the instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an
application arranged by category such File, Edit, View, Project, etc. An example of a
typical user interaction is as follows:

"From the Filemenu, select theOpen Examples command" means click the Filemenu,
then clickOpen Examples to open an explorer window to the Examples folder.

l Another alternative is to use the shortcut menu that appears when you right-click. An
example of a typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means select an object, right-
click, and click an option on the shortcut menu that appears.

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps are taken
or what stages the simulation reached, including software files as applicable. This allows more
rapid and effective debugging.

Help Menu

To access help on the Help menu, select Help. Then choose one of the following:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help on the user interface, press F1 to open the appropriate help for the active
product (design type).

You can press F1 while the cursor is pointing at a menu command or while a particular window
tab is open. In this case, the help page associated with the command or open window is
displayed automatically.

4

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

http://www.ansys.com/Support/


Table of Contents
Table of Contents Contents-1

1 - Introduction 1-1

Prerequisite 1-1

Ansys Electronics Desktop 1-1

Enable Legacy View 1-3

2 - DC Analysis 2-1

Set up DC Analysis 2-1

Run DC Analysis & Plot DC-IV Curve 2-4

3 - LNA with Non-Linear Model 3-1

View DC Bias 3-1

Run Linear Analysis 3-3

Create Report 3-4

RF 1 Tone Nonlinear Analysis 3-6

Define RF 1 Tone Analysis 3-10

Define a Power Sweep and Analyze 3-11

Create Results: Pout/TG21 vs. Pin 3-13

Create Results: Spectrum 3-15

Create Results: Wave Form 3-15

Add a Second RF Source to Input port 3-16

Add Intermodulation Analysis Setup and Analyze 3-17

Create Results: Pout vs Pin 3-19

Create Results: Calculate IP3 3-20

Create Results: Intermodulation Spectrum 3-21

Harmonic Balance: Setup and Options 3-21

Circuit Design Training Manual: Low Noise Amplifier Part II

Contents-1

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Contents-2

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

Circuit Design Training Manual: Low Noise Amplifier Part II



1 - Introduction
This document covers the following topics:

l Circuit Simulation
l Schematic Capture
l DC Analysis
l Linear (S-parameter) Analysis
l Nonlinear Analysis
l Single Tone
l Compression
l Multi Tone
l Intermodulation

Prerequisite
To perform the training exercise, you need the relevant designs and the corresponding footprints
available at the following location: Examples>Circuit>Low Noise Amplifier.

Ansys Electronics Desktop
The Ansys Electronics Desktop, illustrated in the following figure, provides a comprehensive
environment for designing and simulating various electronic components and devices.

Circuit Design Training Manual: Low Noise Amplifier Part II
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Figure 1-1 ANSYS Electronics Desktop

The desktop supports many design types. All design types appear as icons on the toolbar and
under the Projectmenu. For simulating Low Noise Amplifier using an S-parameter model of
NEC NE68133 BJT, select Circuit Design.

Introduction 1-2
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Figure 1-2 Project menu

Enable Legacy View
To view orientations consistent with the instructions and images in the guide, enable legacy view
navigation.

1. Go to Tools > Options > General Options.

2. From the Options window, expandGeneral and select User Interface.

Introduction 1-3
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3. Check Enable Legacy View Navigation

Introduction 1-4
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2 - DC Analysis
This section shows how to set up the Low Noise Amplifier schematic and define a DC analysis
before running the simulation. Set up the schematic as follows:

1. Go to File > Open Examples > Circuit > Low Noise Amplifier and select LNA_DC_IV_
Start.aedt.

2. Save the file in a different location other than the Examples folder.

The Low Noise Amplifier schematic of the inserted design has the circuit shown in the following
figure. The circuit uses a non-linear model for the transistor (using a SPICE library file instead of
the S-parameter data file).

Figure 2-1 Circuit

Set up DC Analysis
1. From the Project Manager window, expand the Project Tree and active design folder.

Then right-click Analysis and select Add Nexxim Solution Setup > DC Analysis to
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open the DC Analysis window.
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2. Click Add on the DC Analysis window.
3. From the window, click variable VB and define a Linear step sweep 0.75 to 0.85 with step

0.01 and clickOK.

4. Select VC and define two Linear step sweeps: 0 to 0.5 step 0.01, click Add ; then 0.5 to 5
step 0.5, click Add,, then clickOK .

DC Analysis 2-3
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5. From the Add/Edit Sweep window, clickOK to accept the settings.

Run DC Analysis & Plot DC-IV Curve
1. From the Project Manager window, expand the Project Tree and active design folder.

Then right-click DC Analysis and select Analyze.
2. Right-click Results and select Create Standard Report > Rectangular Plot.
3. Select VC on the Primary Sweep, Current under Category and Inegative(Ic) under

Quantity as shown in the following figure.

DC Analysis 2-4
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4. From the Families tab, click the ellipsis under Edit and select All value for VB.

5. Click New Report and Close.

DCIV Curves are generated as shown in the following figure.

DC Analysis 2-5
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Note: If you just want the value for current probes, check DC Display options as shown
in the following figure.

DC Analysis 2-6
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3 - LNA with Non-Linear Model
Non-linear model for the transistor using a SPICE library file in the circuit of the project LNA_RF_
1_Tone_Start instead of an S-parameter data file.

Select the project LNA_RF_1_Tone_Start.aedt on the Low Noise Amplifier folder under
Examples > Circuit.

Note: Caption boxes and oval shapes are added in the figure for clarity. These shapes
do not appear in the actual design in Electronics Desktop.

View DC Bias
The steps to view DC bias are as follows:

1. From the Project Manager window, right-click the LNA_Matched_NL Project Tree and
select View DC Bias Values>Show DC Bias or the icon on toolbar.

Circuit Design Training Manual: Low Noise Amplifier Part II
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DC current and voltage at each node are displayed in the schematic as shown in the following
figure. Select the Show voltage and Show current options on the DC Display Options
window and click Show DC Bias in order to update the design with the corresponding values of
the voltages on the nodes and currents through the branches.

LNA with Non-Linear Model 3-2
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2. Check the bias of the transistor, with 2.5V, 3mA which was the bias point of the S
parameters used for matching.

3. Save the project.

Run Linear Analysis
1. From the Project Manager window, expand the Project Tree and active design folder.

Then right-click Analysis and select Add Nexxim Solution Setup > Linear Network
Analysis.

2. Click Add and define a Linear Step sweep from 0.5 GHz to 2 GHz in steps of 0.01GHz.

LNA with Non-Linear Model 3-3
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3. Select Enable Noise Calculation and clickOK.
4. From the Project Manager window, expand Project Tree > active design folder >

Results. Then right-click LinearFrequency to start simulation.

Create Report
1. From the Project Manager window, expand the Project Tree and active design folder.

Then right-click Results and select Create Standard Report > Rectangular Plot:
dBS21, dBS11, dBS22, and NF in dB.

LNA with Non-Linear Model 3-4
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2. After selecting the options shown in Figure 15, click New Report to create the S-
parameter plot.

3. Select Noise figure as shown in the following figure and click Add Trace and Close.
4. Rename the report to S Parameters & NF.

Using the non linear model, it is possible to run a linear analysis.

LNA with Non-Linear Model 3-5
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The non linear model is linearized at the bias condition and the simulation computes the
corresponding small signal S parameters. This allows the user to check that the results using the
non linear model are close to those obtained with the S parameter data file

RF 1 Tone Nonlinear Analysis
1. Double-click the input port symbol to open the Port Definition window.

LNA with Non-Linear Model 3-6
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2. Click Edit Sources to open the Configure Ports and Sources window.
3. Ensure that Input is selected under Ports List and Power and Sinusoidal are selected

under Add New Source.

LNA with Non-Linear Model 3-7
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4. Click Add to selected port and edit Name to RF_IN .
5. Select Property POWER and enter Pin (local variable, -10dBm) as the value of property

POWER.
l In the Add Variable window, type -10dbm in the Value field and press Enter.
6. Select Property FREQ and enter F_IN (local variable, 0.9GHz) as the value of property

FREQ.
l In the Add Variable window, type 0.9GHz in the Value field and press Enter.

LNA with Non-Linear Model 3-8
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7. Select Property TONE and enter F_IN as the value of Property TONE and clickOK.

LNA with Non-Linear Model 3-9
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8. Review the Configure and Port window to ensure that the final settings resemble those
shown in the following figure.

9. ClickOK.

Define RF 1 Tone Analysis
The Select Analysis window allows the user to match specific Sources (e.g., Power Sources,
Voltage Sources) with specific Analysis setups. This offers the flexibility to have multiple
Sources and multiple Analysis setups, then match them accordingly. ClickOK to continue.

From the Project Manager window, window expand the Excitations option to verify that the
source RF_IN is added. Notice that the schematic symbol for the input port has a different
appearance indicating that a source is present.

LNA with Non-Linear Model 3-10
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Define a Power Sweep and Analyze
1. From the Project Manager window, expand the Project Tree and active design folder.

Then right-click Analysis and select Add Nexxim Solution Setup ... > Harmonic
Balance (1-Tone) to open the Harmonic Balance Analysis window.

LNA with Non-Linear Model 3-11
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2. Enter the following settings:

LNA with Non-Linear Model 3-12
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l Name = Psweep.
l Max. Harmonic Number = 7.
l F1 value = F_IN.
3. In the Sweep Variables group box, click Add and select Pin on the Variable drop-down

menu and set Linear Step from -40 dBm to 10 dBm in steps of 1 dBm.

4. Click Add and accept the settings by clickingOK.
5. Expand Analysis and right-click Psweep. Then select Analyze to start simulation.

Create Results: Pout/TG21 vs. Pin
1. From the Project Manager window, expand the Project Tree and active design folder.

Then right-click Results and select Create Standard Report > Rectangular Plot.
2. Select Psweep in the Solution field and Sweep in the Domain field.
3. Select Power, P(Output)<F1>, dBm to plot the output power at Port 2 for the fundamental

F1 and click New Report.

LNA with Non-Linear Model 3-13
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4. Select Transducer Gain, TG(Output, Input)<F1,F1>), dB to plot the transducer gain
between fundamental at port1 and fundamental at port2.

5. Click Add Trace and close the window.
6. From the Project Manager window, click Pout trace and in the Properties window set Y

axis to Y2.

LNA with Non-Linear Model 3-14
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Create Results: Spectrum
1. Right+Click Results and select Create Standard Report/Rectangular Plot.
2. Select PSweep in Solution field and Spectral in the Domain field.
3. Select Power P(Output) in dBm and from the Families tab set variable Pin to -15dBm.
4. Click New Report and Close.
5. Rename the plot to Pout Spectrum.

Create Results: Wave Form
1. From the Project Manager window, expand the Project Tree and active design folder.

Then right-click Results and select Create Standard Report/Rectangular Plot.
2. Select PSweep on the Solution drop-down menu and Time in Domain field.
3. Select Category: Voltage, Quantity: V(Output), Function: none

LNA with Non-Linear Model 3-15
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4. In the Families tab, for variable Pin, click Edit and select Pin = -40, -30, -20, -10 dBm for
the Pin values. Click to close the window.

5. Click New Report and Close.

Add a Second RF Source to Input port
1. Double-click the input port symbol to open the Port Definition window.

Notice that the RF_IN power source is already present in the Source List group box
as shown in the following figure.

2. Click Edit Sources to open the Configure Ports and Sources window.

3. Check that the “Input” port is selected under “Name” in the Port group box and in the “Add
New Source” area ensure “Power” and “Sinusoidal” are selected.

4. Click Add to selected port and edit Name to RF_IN2.
5. Select Property POWER and enter Pin (recall the Pin variable was created earlier).

LNA with Non-Linear Model 3-16
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6. Select Property FREQ and enter F_IN2 (local variable, 901MHz) as the value of property
FREQ.

7. In the Add Variable window type 901MHz in the Value field and press Enter.
8. Select Property TONE and enter F_IN2 as the value of property TONE.
9. ClickOK to bring up the Select Analysis window.

The Select Analysis window allows you to match specific Sources (e.g., Power Sources,
Voltage Sources) with specific Analysis Setups. This gives you the flexibility to have multiple
Sources and multiple Analysis Setups , then match them accordingly.

The Configure ports and sources window should look as shown in the following figure.

Notice that the schematic symbol for the input port now has a different appearance indicating
that 2 Sources are present.

Add Intermodulation Analysis Setup and Analyze
1. From the Project Manager window, expand the Project Tree and active design folder.

Then right-click Analysis and select Add Nexxim Solution Setup > Harmonic Balance
(N-Tone).

2. Enter the following settings:
l Set Name as InterMod
l Click Edit Tones/Maxk and set No. of Tones to 2
l Set F1 to F_IN and F2 to F_IN2, MaxK=5 for both.
l ClickOK.
3. Click Add in the Sweep Variables area and set Linear Step from -40 dBm to 0 dBm in

steps of 1dBm for the variable Pin.
4. Click Add >OK.

LNA with Non-Linear Model 3-17
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LNA with Non-Linear Model 3-18
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5. Under Analysis, right-click InterMod and select Analyze to start the simulation.

Create Results: Pout vs Pin
1. From the Project Manager window, expand the Project Tree and active design folder.

Then right-click Results and select Create Standard Report > Rectangular Plot to open
the Report window.

2. Select InterMod on the drop-down Solution field and Spectral on the Domain field.
3. Click Edit under Harmonics and include F1 and -F1+2F2 as Defined Outputs.
4. Select Power, P(Output)<F1>, dBm and click New Report to plot the output power at

Output port for the fundamental.
5. Select Power, P(Output)<-F1+2F2> , dBm, click Add Trace to plot the output power at

Output port for the IM3.
6. Click Close.
7. Rename the plot to Pout vs pin InterMod.

See the difference in slopes between the fundamental and third order products. As expected,
the third order term has a slope that is 3 times unity in linear region.

LNA with Non-Linear Model 3-19
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Create Results: Calculate IP3
1. From the Project Manager window, expand the Project Tree and active design folder.

Then right-click Results and select Create Standard Report > Data Table.
2. Select InterMod in Solution field and Sweep in domain field.
3. ClickOutput Variables ... to open the Output Variables window.
4. Enter in the expression field :

dBm(P(Output)<F1>)+(dBm(P(Output)<F1>)-dBm(P(Output)<-F1+2F2>))/2

5. Enter in field Name: IP3, and click Add and Done.
6. Select Output Variable in Category, IP3 in Quantity None as Function, and in Primary

Sweep select Pin value =-34dBm.
7. Click New Report and Close.

LNA with Non-Linear Model 3-20
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Create Results: Intermodulation Spectrum
1. From the Project Manager window, expand the Project Tree and active design folder.

Then right-click Results and select Create Standard Report > Rectangular Plot to open
the Report window.

2. Select InterMod on the drop-down Solution field and Spectral on the Domain field.
2. From the Families tab, click Edit, select Pin =-4 dBm, and on the Traces tab, select

Power, P(Output), dBm.
3. Click New Report, and click Close.
4. Rename the plot to Intermodulation Spectrum.

Harmonic Balance: Setup and Options
Harmonic Balance Analysis can be controlled using the options shown:

l Max Harmonic Number: Max harmonics computed in the solution (MAXK)
l F1 value is the single tone frequency, using a variable F_IN in this example.

The Method parameter selects between the standard harmonic balance calculation and a
shooting method that facilitates single-tone analysis of circuits with strongly nonlinear behavior.

l Method=HB, standard harmonic balance, is the default for single-tone analysis and is
always used for multi-tone harmonic balance analysis.

LNA with Non-Linear Model 3-21
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l Method=Shooting is available for single-tone analyses only. When method is set to
shooting, single-tone harmonic balance uses a time-domain shooting method that is
efficient for nonlinear circuits. This option is ignored for multi-tone harmonic balance.

Transient Initial Time set to a positive non-zero value is representing time required for Transient
to stabilize before HB begins using the result.

With Auto_Refine_Solution=yes, Nexxim examines the result at each sweep iteration to
determine if the solution is sufficiently resolved. If it is not, Nexxim doubles the number of
harmonics and repeats the iteration. Thus, you can start the sweep with MAXK set to a low
number, and have Nexxim automatically adjust MAXK as needed to maintain accuracy.
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